1. Welcome to Black Dahlia, an adult 18+ roleplaying and writing forum! Don't forget to vote daily for BDRP! The more you vote, the more awesome writers find BDRP, so vote each day! Click here to vote on Top RP Sites and here to vote on Top Site List.

 Bug Theme Bugs and Issues - Please Post Here For Any Theme Bugs

Discussion in 'Questions & Suggestions' started by Alchemy, Sep 11, 2017.

  1. Alchemy

    Alchemy The Rebel Queen Administrator

    Messages:
    1,670
    Local Time:
    5:09 PM
    @Iniquity I believe Dalliance is going to look into upgrading the prefix add-on to see if that helps make it more functional. We can ask the developer for assistance as well, to see if they have any suggestions.
     
    Iniquity likes this.
  2. Iniquity

    Iniquity I'm already dead. Community Helpers

    Messages:
    168
    Local Time:
    1:09 AM
    Oh maybe I miss read, I was thinking just to mention it because they should definitely fix it for you.
    Thanks for the clarification! :)
     
  3. Alchemy

    Alchemy The Rebel Queen Administrator

    Messages:
    1,670
    Local Time:
    5:09 PM
    They may or may not, sadly, because it sounds like it's a conflict with the theme, not an actual break on their end. Flat Awesome and the Prefix add-on are created by independent developers, so the conflict may have more to do with conflicting code between the two "add-ons" and less to do with a glitch on the developer end, if that makes sense? Either way, we can check if it needs and upgrade and possibly contact Brivium (the Prefix developer) to see if they have any suggestions.
     
    Iniquity likes this.
  4. Laz

    Laz I want to believe. Member

    Messages:
    16
    Local Time:
    6:09 PM
    I found an odd bug on my profile page, regarding the profile cover picture. After uploading a new profile cover, the old cover still appears briefly underneath the new cover when refreshing or loading the page. It also still shows as being my profile cover when attempting to change the profile cover.

    I deleted my profile cover entirely, which then showed nothing, and the old profile cover did not appear again when selecting a new profile cover to replace the blank field. Oddly enough, however, after successfully upload and displaying the new (and different) profile cover, it goes back to doing the exact same thing - shows briefly underneath the new one, and shows as being my current profile cover. (Unfortunately it only appears briefly and I was unable to capture that part.)

    I've also tried it with multiple themes, and it appears to an issue that's independent from the themes, as it persisted each time.

    Not really a problem, but I thought it was an odd bug and wanted to report it for the sake of documentation. I'd be curious to know if anyone else has experienced this bug.

    Changing profile pic: bugged_profile_cover.PNG
    After deleting profile pic: bugged_profile_cover2.PNG
    After adding new profile pic: bugged_profile_cover3.PNG
     
  5. Ki7Ka7

    Ki7Ka7 Just a stray mutt without a safe space Member

    Messages:
    42
    Local Time:
    7:09 PM
    upload_2018-8-10_9-28-58.png

    This is a bug in Flat Awesome Dark and Flat Awesome Dark - Blue

    If these styles are to be kept, it'd be nice if all of the edit buttons were legible. I disabled my css editing add-on just to make sure that it wasn't my own edits messing things up, and sure enough, it seems to be an actual issue with the style. -_-;; (Then playing around with the CSS, I can't find a fix for it, so I can't suggest anything.)

    I use Justify and Apply Default Formatting a lot. On the computer, I can hover to figure out what is what, but I don't have that luxury on my phone.

    There are a couple of other minor areas that are also messed up. Such as threads being unable to be replied to having that text blend in with the background...
    upload_2018-8-10_9-34-9.png
    But that's not such a big deal, lol.
     
  6. Nevermind

    Nevermind The Lost Paragon Administrator

    Messages:
    1,276
    Local Time:
    4:09 PM
    The non-visible buttons on the Rich Editor are an issue with the add on itself, not necessarily the theme. Because Flat Awesome is a theme we purchased and we aren't as familiar with the coding, we will discover that certain add ons clash with one another on the purchased themes. Buttons being "invisible" on the rich editor is a minor issue that is not unique to Flat Awesome, but it would take massive digging through CSS to fix and isn't a minor edit, unfortunately. Something we can look into at some point when we are more familiar with the coding and can hopefully figure out where the conflicting codes lie.

    As for the second issue, that IS something I can probably fix but I'm going to need a full screen screen shot to actually see what you're talking about.
     
  7. Ki7Ka7

    Ki7Ka7 Just a stray mutt without a safe space Member

    Messages:
    42
    Local Time:
    7:09 PM
    It's the locked alert and thread alert text color. This is the CSS that I did to fix that, which should help you alter it on your end, lol. (So far, it has fixed the areas that I've seen the text blend in with the background, but I'm sure I haven't seen all locked threads and their alerts.)
    If nothing else, this should get you in the ballpark, right?

    .lockedAlert {
    color: rgb(153, 153, 153);
    }

    .threadAlerts dd {
    color: rgb(153, 153, 153);
    }


    It sucks that the invisible buttons is a "minor" issue with less than minor fixes to it TT_TT Especially since this is the only theme that's being kept that doesn't bother me that much. I guess that just leaves not doing mobile replies as the only option in that regard.
     
  8. Nevermind

    Nevermind The Lost Paragon Administrator

    Messages:
    1,276
    Local Time:
    4:09 PM
    As I said, a picture goes a long way, but I will find a picture myself and look into it, thanks for the heads up.

    As for justify, it may be annoying but you can always use the bbcode [justify][/justify] to achieve justification, which unfortunately does take a few extra seconds to type but still achieves the effect. Default formatting is the button directly next to the eraser. I'm currently on mobile and have zero issue pressing the button, personally.
     
    Ki7Ka7 likes this.
  9. Nevermind

    Nevermind The Lost Paragon Administrator

    Messages:
    1,276
    Local Time:
    4:09 PM
    @Ki7Ka7

    So, hilariously enough, while I still haven't fixed the invisible thread status thing, with help from Alchemy I found a work around for your editor issue. Instead of digging through countless lines of code, I took the the lazy route and copied code from a theme that was functional and just replaced the whole damn thing. A little color editing and boom, the editor on all Flat Awesome themes should now have fully visible buttons.

    So. You know. I was somewhat productive, haha. I hope this helps you for all those mobile posts. :party:
     
    Ki7Ka7 likes this.
  10. Nevermind

    Nevermind The Lost Paragon Administrator

    Messages:
    1,276
    Local Time:
    4:09 PM
    Okay, the locked thread status have also been adjusted. Feel free to let us know whatever else you find. Thanks!
     
    Ki7Ka7 likes this.
  11. Alchemy

    Alchemy The Rebel Queen Administrator

    Messages:
    1,670
    Local Time:
    5:09 PM
    We tend to just dig around until we find a fit. Thanks for pointing this out @Ki7Ka7

    We're really doing our best to make sure the themes are functional and not blending, but Xenforo has a million little pieces and you touch one and break another. lol. Their built-in system also doesn't cover every part of the forum, so we're often digging through the HTML templates to figure it out. And sometimes two very similar bits of code are housed in two different templates...Or more. That's why we appreciate ya'll pointing it out when you find something wonky. There's just....So much. O.O
     
    Ki7Ka7 and Nevermind like this.
  12. Ki7Ka7

    Ki7Ka7 Just a stray mutt without a safe space Member

    Messages:
    42
    Local Time:
    7:09 PM
    I didn't post a screenshot because I was on my phone. And, admittedly, I don't know how to take a full screenshot from my phone XD (The side of hand, swipe left only results in the apps jumping and just bleh. And that's SUPPOSED to be how I do screenshots on it. And the partial screenshot doesn't expand enough to show enough of the post to be more useful than I already provided...)

    I was also in a dead zone for a good portion of that. I was trying to get you what I could before we hit that dead patch, hence the re-typing of the css code I used XD (It was quicker than fumbling with a screenshot that I couldn't get) So I apologize that I didn't get you exactly what you needed.

    Wow, you were very productive while I was in the dead zone ♥♥♥ This is awesome, and makes life a ton easier =D Thank you~

    This applies to all coding XD I can understand that, trust me. I used to work on a website where me and the other owner had done everything from scratch. After three years, having to fix something that was broken from the first month of being open was a real pain in the neck. (Especially when I was sent to fix the coding that the other guy did because he was being way too lazy to stop playing video games to try and fix it...)

    Eventually, we just said "screw it" and started on a re-code of everything, from scratch and updated, only for things to fall out between us.

    So, I can understand digging and poking around until you either find a fix or break fifteen other things in the process XD It's just irritating to go from a skin that took a total of 3 lines of code in the add-on to fix [Literally minor things that don't affect day-to-day use of the site at all] to having to use something broken that I couldn't even temporarily fix for myself [when I use it daily/multiple times a day when I post]. Now that the biggest issue is handled, at least for me, I am not as irritated about losing the style I have gotten used to. (Change is never fun. And I understand why this one must be done. I just want to make sure my new option properly works is all XD)

    My ranting/rambling ends here. If I find something else, I'll try to be helpful with getting it fixed instead of just complaining about it then vanishing. :p

    I'm not sure how well this is worded and all. -Coughs-
    So the TL;DR version - I really appreciate that you all found a way to get it working =3 Thank you =D
     
    Nevermind and Alchemy like this.
  13. Alchemy

    Alchemy The Rebel Queen Administrator

    Messages:
    1,670
    Local Time:
    5:09 PM
    A lot of times too, it's just things we didn't see. Styles sadly have like so many moving parts, that even after spending hours and hours on one, I still miss things. We usually have a few mods/members check a style before we wide release it, but even then things slip through the cracks. And Add-ons tend to be particularly cranky and at times are insanely difficult to modify, because they are coded by someone outside of the style code.

    Sadly, as I mentioned in the announcement, we were getting to a point where style upkeep was taking hours and hours. And that's just for like small things, like add-on compatibility and updating affiliates. It's also taken a bulk of time to create/modify the new themes, but some do provide customization options for folks that aren't code savvy. It was really about striking a balance so we could do upkeep, but also RP and use the site. lol.
     
    Ki7Ka7, Nevermind and Manaan like this.

Share This Page